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Introduction 

Welcome to the Upgrade Guide for Juris Suite 2.6.  This document is for firms upgrading to the latest 
version of Juris Suite. This is for upgrades from MyJuris 1.1 and all versions of Juris Suite. If you are 
performing a new installation of Juris Suite and do not have a previous version then follow the new install 
guide available on the Juris Support Center.   

Upgrading Summary 

Upgrades from MyJuris 1.1 and JurisSuite Pre-2405 

 Download installation files via the support site, http://support.lexisnexis.com/Juris/  

 Uninstall all MyJuris and JurisSuite Components from Server 

 Install and Configure JurisSuite Components on the server 

 Configure IIS 

 Deploy Updates 

 Uninstall all MyJuris and JurisSuite Components from the Client 

 Install JurisSuite Client 

Upgrades from 2405 and above versions of JurisSuite 

 Download Updates using Deployment Manager 

 Uninstall JurisSuite Server 

 Install Downloaded JurisSuite Server 

 Configure IIS 

 Deploy Updates 

 Ensure that the JurisSuite Client upgrades automatically (the client should auto-update upon the 
next login) 

 

Planning and Preparation 

System Requirements 

Juris System Requirements can also be viewed at the LexisNexis Support Center by clicking on Juris 
System Requirements. The below requirements specifically focus on the JurisSuite program. 

Server Required Pre-Install Items 

 Juris version 2.6 must be installed  and configured prior to installing JurisSuite 2.6. 

 Windows Server 2003 or Windows Server 2008 ** (Note:  Windows Server 2008 requires IIS 
6.0 Management Compatibility Components.  See below for implementation instructions) 

 SQL Server 2005/2008, SQL Server 2005/2008 Express (4GB database limit),  
SQL Server 2008 R2 Express (10GB database limit)  

 .NET 4.0 Framework Installed 

 IIS Installed  (Note: If running Windows Server 2003 in 64 bit mode, see the section immediately 

following this checklist.) 

See also this document: IIS 7 Setup Guide  

http://support.lexisnexis.com/juris
http://support.lexisnexis.com/Juris/
http://support.lexisnexis.com/juris
http://juris.com/jurishelp/Content/Resources/Images/Document%20Downloads/IIS%207%20Setup.pdf
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 2GB of Available  Local Hard Drive space  

 540MB for Installation 

 570MB for Staging Information 

 700MB of available for deployment 

 JurisSuite installer must have administrative privileges. 

 An Outside IP address is required for WebConnect setup. 

 

Windows Server 2003 running in 64 bit mode 

JurisSuite can only be run in a 32 bit environment. To adjust a 64 bit Windows Server O/S to properly run 
JurisSuite, follow these directions.  Note: We highly recommend you engage the services of a qualified 
network technician to implement the changes below. 

Switch ASP.NET to run in 32 bit mode – Reference Microsoft KB Article 894435 

1. Click the Windows Start button and then click Run. The Run window opens. 

2. Type cmd and then click OK. 

3. Type the following command and press ENTER to enable the 32-bit mode: 

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET 

W3SVC/AppPools/Enable32bitAppOnWin64 1 

4. Click OK. 

5. Click the Windows Start button and then click Run. The Run window opens. 

6. Type cmd and then click OK. 

7. Type the following command and press ENTER to install the version of ASP.NET 4.0 (32-bit) and 
to install the script maps at the IIS root and under: 

%SYSTEMROOT%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe –i 

8. Click OK. 

9. Make sure that the status of ASP.NET version 4.0.30319 (32-bit) is set to Allowed in the Web 

service extension list in Internet Information Services Manager. 

 

Switch WebDAV to the 32 bit version and disable the 64 bit version 

1. Click Start > Settings > Control Panel > Administrative Tools > Internet Information 
Services 

2. Expand Web Server Extensions. 

3. Click “Add a New Web service extension...” 

4. Name the Extension  “WebDAV32” 

5. Click Add for the required files and browse to C:\WINDOWS\SysWOW64\inetsrv\httpext.dll.  

6. Check “Set Extension status to Allowed” 

7. Click OK 

8. Highlight WebDAV (the 64 bit version) and prohibit the extension. 

 

http://support.microsoft.com/kb/894435
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Windows Server 2008 running in 64 bit mode 

Before installing JurisSuite server, IIS 6.0 Management Compatibility Components must be installed.  
Failure to do so will result in the server installation rolling back. 

To install IIS 6.0 Management Compatibility Components using Windows Server 2008 Server Manager: 

1. Click Start > Administrative Tools > Server Manager. 

2. In the left navigation pane, expand Roles, right-click Web Server (IIS), and select Add Role 
Services. 

3. On the Select Role Services pane, find the IIS 6 Management Compatibility section and place a 

check mark in each of the following boxes: 

 IIS 6 Metabase Compatibility 

 IIS 6 WMI Compatibility 

 IIS 6 Scripting Tools 

 IIS 6 Management Console 

Recommended Configurations  

Changes based on user count – All other minimum requirements still apply. 
 

 1-20 Users 
o Single/Dual Xeon Processor 
o Windows Server 2003 R2 ** 
o MS SQL Server 2005 ** 
o 2GB RAM or higher* 

 21-50 Users 
o Dual Xeon Processor 
o Windows Server 2003 R2** 
o MS SQL Server 2005 ** 
o 3GB RAM or higher* 

 51+ Users 
o Quad Xeon Processor 
o Windows Server 2003 R2 
o MS SQL Server 2005 
o 4GB RAM or higher* 

Additional Information 

* The database server computer should be equipped with minimum 2GB of RAM plus 32 MB of RAM per 
active user (the estimated number of users concurrently accessing the server at any one time). 
Inadequate memory for the number of concurrently accessing users will reduce performance. 

** Vista and Windows 7 are NOT supported as a server platform for Juris products. Windows Server 2008 
and Juris 2.35 SP1 are supported with known issues.  Before upgrading to Windows Server 2008, please 
read the compatibility document found at http://support.lexisnexis.com/Juris/.  All operating systems and 
SQL instances should be updated to the current releases of service packs and updates marked critical. A 
competent network engineer should be available to help troubleshoot any issues that arise.  Windows 
Server 2008 platform requires specific IIS settings that must be done prior to installation.  These 
instructions are found on page 16 of this document.       

*** If you are using Windows Server 2003, WebDAV, ASP.NET, and Active Server Pages must be 
installed and allowed in IIS Web Service Extensions. 

http://support.lexisnexis.com/Juris/
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Workstation Required Pre-Install Items 

 Juris 2.6 Application or License Manager must be installed 

 .NET 4.0 Framework 

 User has local administrative rights * 

Recommended Configuration for Workstations 

 Intel Duo Core processor (Or AMD equivalent) 

 Display Resolution set at 1280x1024 with Normal 96dpi. 

 XP Professional, Vista Business or Ultimate, Windows 7 Professional or Ultimate **. 

 2GB RAM (Normal Users) or 3GB RAM (Power Users) 

Note: A power user is considered someone who uses both Juris and JurisSuite along with other products 
(like Outlook, Word, Excel, Adobe Acrobat Reader etc.) all at the same time. 

Additional Information 

*If Local Administrative rights cannot be given, please follow the Limited-Rights Environment document 
located on the Support Center website.  

**JurisSuite is not supported on Vista Home Edition or Windows 7 Home Premium.  If you are using Vista 
Business/Ultimate, or Windows 7 Professional/Ultimate, you must have User Account Control disabled 
installing the JurisSuite Client.   

Citrix/Terminal Server Environments 

 Juris supports operation on Citrix® MetaFrame® and Windows Terminal Server. Setup and 
configuration are not supported by Juris and should be completed by a qualified Systems 
Administrator. In such environments, the Juris database must reside on a separate server from 
that used for Citrix or Terminal Server. 

 JurisSuite is not available as Thin Client software. JurisSuite operations in these environments 
require large amounts of RAM and sometimes multiple server configurations performing load 
balancing. 

Juris Database Backup 

After the checklist for hardware and software requirements has been met, it is best practice to backup 
using the Juris Management Console. Documentation on Juris Management Console Backup is located 
on the Support Center website. 

Juris Support Contact Information 

By Phone: 877-377-3740 

Juris Support Center: http://support.lexisnexis.com/juris 

Additional How-To Information: http://www.juris.com/jurishelp  

http://support.lexisnexis.com/juris/record.asp?ArticleID=6731
http://support.lexisnexis.com/juris/record.asp?ArticleID=6366
http://support.lexisnexis.com/juris
http://www.juris.com/jurishelp
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Upgrades from MyJuris 1.1 and Juris Suite Pre-2405 

Server 

Uninstalling Existing Juris Suite Server 

If you have an earlier version of the Juris Suite Server installed, you must uninstall it before installing the 
current version. To uninstall the server, complete the following: 

1. Open the Windows Control Panel.  

2. Click Add or Remove Programs. The Add or Remove Programs window opens. 

3. Click JurisSuiteServer in the list of installed programs to highlight it. 

4. Click the Remove button. Click Yes to confirm removing JurisSuiteServer from the computer.  

5. Wait for the uninstallation process to complete. Close the Add or Remove Programs window. 

Download the Installation Files 

1. Using a web browser, navigate to the http://support.lexisnexis.com/Juris/ 

2. Click on Juris and JurisSuite under Downloads and Utilities. 

3. Click the JurisSuite downloads link. 

4. Follow instructions on the site to save the installation files to a shared location. 

Uninstall Previous MyJuris and JurisSuite Components 

1. Open Add/Remove Programs by going to Start >Control Panel > Add/Remove Programs.  

2. Locate and uninstall the following programs from the server (depending on what version is 
currently installed, you may not see all of the items listed below): 

 Deployment Manager 

 Deployment Manager Web Service 

 JurisSuite Client 

 JurisSuite Distribution Service  

 JurisSuite Distributed Reports 

 JurisSuite Server 

 MyJuris 

 MyJuris Web Service 

3. Open IIS Manager by going to Start > Programs > Administrative Tools > Internet 
Information Services 

4. Under Default Web Site right click and delete any of the following  sites: 

 JurisSuite Updater 

 Juris Dashboard Server 

 Juris Distributed Reports 

 Juris WebConnect 

 JurisSuite WebConnect 

 MyJuris Deployment 

5. Open Services by going to Start > Programs > Administrative Tools > Services 

6. Make sure the following Services were removed: 

http://support.lexisnexis.com/Juris/
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 Juris Alert Service  

 Juris Distribution Service 

If the services above are still loaded, perform the following steps to remove the service.  

 Right click the service and go to properties. 

 Write down the exact service name on the General tab.  

 Click the Stop button if the service is running.  

 Open a command prompt by going to Start>Run and typing cmd and click OK. 

 Type the following command at the prompt. SC DELETE <ServiceName> where 

<ServiceName> is the exact service name you obtained from the General Tab above.  

 Press Enter and then check Services again for that service. If it‟s still listed, a reboot may be 
required. 

 Caution: When deleting folders, be sure to check the contents of the folder prior to deletion. This 
prevents accidental deletion of files that were improperly stored in the folder.  

7. Delete the following folders and all subfolders:  

 Program Files\Juris    (Not Juris2) 

 Program Files\JurisSuite 

 Program Files\Deployment Manager 

 Program Files\JurisSuite Alerting Service 

 Program Files\Distribution Service 

Install JurisSuite Server (If using Windows Server 2008, see page 5 for IIS 6.0 
Compatibility Component Installation before proceeding) 

1. Locate the extracted installation files and double click on the JurisSuiteServer.exe file to begin 
the installation.  

 

 

2. Click the Next button on the Welcome installation screen. 
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3. Select “Accept” on the license agreement window and click the Next button. 

  

 

4. Enter the appropriate Customer Information and click the Next button. 
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5. On the Setup Type window, if JurisSuite is being installed to the Local Disk C: drive, accept the 
default of Complete, click the Next button and skip to step 14. Otherwise if installing on any drive 
other than C:\ you should select Custom and click the Next button. 

  

6. From the Custom install screen, you will need to select the Updater combo box under the 
JurisSuite IIS Products. Select “This feature, and all sub features, will be installed on local 
hard drive.” 
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7. Click the Install button to execute the installation of the server application. 

  

8. Click the Finish button on the final window. 
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Configuration of IIS on Windows Server 2003 

To configure IIS properly for JurisSuite, perform the following: 

1. Start the IIS management console.  This can be accessed from within the Administrative Tools. 
Start > All Programs > Administrative Tools > Internet Information Services Manager 

2. Expand the server in the left hand pane. 

  

3. Expand the web sites. Right click on the JurisSuite Updater and select Properties.  
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4. On the Virtual Directory tab, click the Configuration button.  

  

5. Select .config extension, and click the Remove button. 

 

6. Click the Yes button to confirm removal of the extension. 
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7. Click the Options tab, and place a check in the Enable parent paths box.  

  

8. Click the OK button. 

9. Click the Directory Security tab, and click the Edit button under Authentication and access 
control. 
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10. Place a checkmark next to the Integrated Windows Authentication if no checkmark exists.  
Click the OK button.  

 

11. Select the HTTP Headers tab.  Click the MIME Types button in the MIME types section. 
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12. Click the New… button in the MIME Types window. 

 

13. Enter each of the following types into the Extension and MIME type fields.  Be sure to add the 
period before each extension.  Click the OK button.  Repeat steps 13 and 14 until all the types 
are added. 

 .conf 

 .dat  

 .fmt 

 .isl 

 .msg 

 .sql 

 .config 
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14. When you have completed, the window should look like the figure below.  Click the OK button 
when complete. 

 

15. Click the ASP.NET tab. Select ASP version 4 from the ASP.NET version drop-down list. 

Note: For 64 bit servers, disregard this step. The ASP.NET tab will not appear when running a 64 
bit server in 32 bit mode. (32 bit mode is required for JurisSuite IIS sites.) 

  

16. Click the OK button on the JurisSuiteUpdater Properties window. 
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17. Right click on the JurisDashboardServer and select Properties.  

18. Click the ASP.NET tab. Select ASP version 4 from the ASP.NET version drop-down list. 

Note: In a 64 bit environment, the ASP.NET tab will not due to 32 bit mode being enabled for IIS. 
This is a required IIS state for JurisSuite to function properly in 64 bit environments. 

  

19. Ensure the C:\inetpub\wwwroot\JurisDashboardServer\ folder has full access to 

Network Services. 

Note:  If running Windows Server 2003, WebDAV, ASP.NET, and Active Server Pages have to be 
installed and allowed in IIS Web Service Extensions. 

20. Click the OK button on the JurisDashboardServer window. Close the Internet Information 
Services window. 
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Confirm that JurisSuite IIS sites are running in ASP.NET 4.0 (Windows Server 2003) 

1. Click the Windows Start button and then click Run. The Run window opens. 

2. Type cmd and click OK. A command line window opens. 

3. Type the following commands, pressing ENTER after each one: 

cd/ 

c: 

cd windows\microsoft.net\framework\v4.0.30319 

aspnet_regiis -lk  

4. Confirm that you see JurisSuiteUpdater, JurisDashboardServer, JurisDistributedReports, 

JurisSuiteWebConnect, and JurisWebAPI as shown below. 

Note: Leave the command window open until you have confirmed that the sites are listed. 

 

If JurisSuite is installed in 32 bit mode correctly you will see a list of all 5 JurisSuite sites come up. This 
indicates that IIS setup Is complete. You can test the sites in Internet Explorer. 

If you do not see the sites (JurisSuiteUpdater, JurisDashboardServer, JurisDistributedReports, 
JurisSuiteWebConnect, and JurisWebAPI), follow this procedure: 

1. Click the Windows Start button and then click Run. The Run window opens. 

2. Type cmd and click OK. A command line window opens. 

3. Type each of the following commands, pressing ENTER after each one: 

cd/ 

c: 

cd windows\microsoft.net\framework\v4.0.30319 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteUpdater 

aspnet_regiis –sn W3SVC/1/ROOT/JurisDashboardServer  

aspnet_regiis –sn W3SVC/1/ROOT/JurisDistributedReports 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteWebConnect 

aspnet_regiis –sn W3SVC/1/ROOT/JurisWebAPI 

iisreset 

aspnet_regiis -lk  

4. Confirm that the list now shows JurisSuiteUpdater, JurisDashboardServer, 

JurisDistributedReports, JurisSuiteWebConnect, and JurisWebAPI. 

 

 

 



 

20 

Configuration of IIS7/Windows Server 2008 

The following steps are for Windows Server 2008 IIS7 Setup. 

1. Select Server Manager>Roles>Web Server (IIS)>Internet Information Services (IIS) 
Manager. 
 

 

2. Expand the server and sites node. 
 

 

3. Select Application Pools. 
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4. In the display pane, click the server name in the left pane. In the IIS area, double-click ISAPI and 
CGI Restrictions. 

 

5. Set the Framework applicable to the server‟s (64 or 32 bit) ASP.NET v4.0.30319 to „Allowed‟. 

6. In the display pane, right click on JurisSuite and select Advanced Settings. 
 

 

7. Ensure that the following settings are enabled: 

 (General) Section 
 

o .NET Framework Version – v4.0      
o Enable 32-bit Application – True (if you are running 64 bit machine) 
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o Managed Pipeline Mode – Integrated 

 

 Process Model Section 
 

o Identity – Network Service 
o Load User Profile – True 

 

8. Click the OK button. 

9. Right click on JurisSuite and select View Applications. 

10.   Ensure the following Applications are listed: 

o JurisDashboardServer 

o JurisDistributedReports 

o JurisSuiteUpdater 

o JurisSuiteWebConnect 
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Set JurisSuite IIS to run in ASP.NET 4.0 (Windows Server 2008) 

1. Click the Windows Start button and then click Run. The Run window opens. 

2. Type cmd and click OK. A command line window opens. 

3. Type the following commands, pressing ENTER after each one: 

cd/ 

c: 

cd windows\microsoft.net\framework\v4.0.30319 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteUpdater 

aspnet_regiis –sn W3SVC/1/ROOT/JurisDashboardServer  

aspnet_regiis –sn W3SVC/1/ROOT/JurisDistributedReports 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteWebConnect 

aspnet_regiis –sn W3SVC/1/ROOT/JurisWebAPI 

iisreset 

 

JurisSuiteUpdater Settings 

1. Under Sites, select JurisSuiteUpdater. 
 

 

2. In the IIS section, double click Request Filtering. 

Note:  In some instances, Request Filtering may not show as below even if it is installed.  Please 
refer to the following article on how to edit the Request Filtering file list via the 
ApplicationHost.config file.    http://support.microsoft.com/kb/942045/  

http://support.microsoft.com/kb/942045/
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3. Ensure File Extension .config is set to „True‟. 

 

 

4. Return to the JurisSuiteUpdate site. You use the back browser button or simply re-select 
JurisSuiteUpdater under Sites. 

5. In the IIS section, double click ASP. 
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6. Ensure Enable Parent Paths is set to „True‟ 
 

 

 

7. Return to the JurisSuiteUpdate site. You use the back browser button or simply re-select 
JurisSuiteUpdater under Sites. 

8. In the IIS section, double click Authentication. 
 

 

 

9. Ensure Windows Authentication is set to „True‟ 
 

 
 

10. Return to the JurisSuiteUpdate site. You use the back browser button or simply re-select 
JurisSuiteUpdater under Sites. 

11. In the IIS section, double click MIME Types. 
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12. Right mouse click in the display pane and select Add.  You can also use the Add link under the 
Actions pane. 
 

 

13. Add the following types.  You must add one at a time, entering „text/plain‟ as the MIME type. 

o .conf 

o .dat 

o .fmt 

o .isl 

o .msg 

o .sql 

o .config 

 
 

Be sure to click the OK button each time to complete the additions. 
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14. In the display pane, click the server name in the left pane. In the IIS area, double-click ISAPI and 
CGI Restrictions. 

 

15. Set the Framework applicable to the server‟s (64 bit or 32 bit) ASP.NET v4.0.30319 to “Allowed”. 
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JurisDashboardServer Settings 

1. Right click on the JurisDashboardServer and select Edit Permissions. 
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2. Select the Security Tab. 

3. Click the Advanced button. 
 

 

4. Select IIS_IUSRS as indicated below, and click the Change Permissions button. 
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5. Select the same IIS_IUSRS entry and click the Edit button. 
 

 

6. Ensure the Create files / write data and Delete subfolders and files is set to „Allow‟ 
 

 

7. Click the OK button.  Click the OK button on each of the open windows. 
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8. For theJurisDashboardServer, ensure Anonymous Authentication, Forms Authentication and 
Windows Authentication are enabled. 

 

 

9. Ensure the C:\inetpub\wwwroot\JurisDashboardServer\” folder has full access to Network 
Services 

10. Exit IIS Manager. 

JurisWebAPI Settings 

No special IIS7 settings are required for the JurisWebAPI. 

However, some additional setup is required to enable full API functionality. For details, please refer to the 
section JurisWebAPI Configuration and Usage. 

IIS7 Configuration is completed. 
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Deployment Manager Installation 

Deployment Manager is the key component to upgrading the Juris database and pushing out updates to 
installed JurisSuite clients on workstations. It is designed to be installed only on the SQL Server. 

1. Navigate to the extracted JurisSuite installation files. Double click the JurisSuiteClient.exe file. 

 

2. Click the Next button on the Welcome window. 

 
 

3. Accept the license agreement and click the Next button. 
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4. Enter the appropriate Customer Information, and click the Next button.  

 
 

5. Choose Administrator and click Next. 

 
 

6. If you only want the Deployment Manager click the Next button.  However, if you want both the 
Deployment manager and the JurisSuite client, click on the X next to JurisSuite and select 
“This feature will be installed on local hard drive”.  Click the Next button. 
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7. Click Install. 

 
 

8. When the installation has completed, click the Finish button. 

Deployment Manager Configuration 

1. Start JurisSuite Deployment Manager.  Start > All Programs >Juris > JurisSuite 
Deployment Manager. 

2. Deployment Manager will load and prompt you to enter and validate some basic information. 

Note: If Deployment Manager does not start up, this means either Deployment Manager wasn‟t 
installed on the SQL server or the SQL Management Objects Collection wasn‟t installed during 
the Pre-Install Requirements section. 
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3. Click the Check Version button. 
 

 
 
Note: Version number will differ from the image above. It is only used as an example. If you want 
to review the release notes for the version listed, click the Release Notes button.  This will launch 
a separate window in the form of a browser. 
 
The next section is for the Staging Path. This is for storing deployment files. Workstations will not 
need access to this folder. 

4. Use the ellipses button (…) to open the “Browse For Folder” Window.  

5. Click once on the root directory that JurisSuite is being installed to. 

6. Click Make New Folder and name the new folder JurisSuiteStaging. Then click OK. 
 

 
 

7. Now that the Staging Path is set we can start downloading files. By clicking on the Download 
Version button. 
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8. You will be asked if you are sure you want to download the latest version of JurisSuite.  Click 
Yes. 

 
 
The files will begin to download. This process can take up to 1 hour depending on your 
connection speed.  A status window displays progress of the files being downloaded. 

 

  
 
Upon completion, a download log will be displayed at the bottom of the main Deployment Page. 
This log is useful in determining cause of a failed file download 
 
The next area to configure is the Last version Deployed section. If you have multiple licenses that 
are licensed for JurisSuite then you will have to come back to this section after deploying and 
select the next Company to be deployed. 

9. Select the Company that you will be deploying JurisSuite against. 

10. Check that the License is Valid and make note of the Database Size. 
 
Note: Servers running SQL Server 2005/2008 Express Edition will not want to deploy if DB Size 
is larger than 3.3GB as this will put the database very close to the 4GB limit after deployment. 
The firm will have to upgrade to a full edition of SQL Server 2005/2008 in order to deploy 
JurisSuite. (For SQL Server 2008 R2 Express, the database size limit is 10GB.) 

11. Replace the word ServerName in the Web Update URL with the name of the server JurisSuite 
Server was installed on. 

12. Click Test to validate the site. 
 
Note: If the site does not validate, be sure that all pre-install requirements were completed. If 
the site still does not validate, contact Juris Support. 

13. Click OK on the validation box. 
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14. Click Yes to the Replace Client Path box. 
 
WebConnect is only used if a remote user does not have a direct connection to the network 
(i.e. VPN clients). If there will be workstations requiring WebConnect follow steps 23 through 
25, otherwise skip to step 26. 

15. Replace the word ServerName in the Web Connect URL with the Outside IP address that remote 
users will be able to access to.  

16. Click Test to validate the site 
 
Note: If the site does not validate, be sure that all pre-install requirements were completed. If the 
site still does not validate, contact Juris Support. 

17. Click OK on the validation box. 
 
The JurisSuite Configuration Settings apply globally and are optional. However, the settings 
are particularly useful for Citrix or Terminal Server environments. If any changes are made to 
this area, be sure to click Apply to set the change. 

 Data Path - This setting is not required for regular environment setups.  It is to be used as an 
alternate path for Juris support files (like cache database). For example: „C:\Juris‟ or 
„C:\Juris\@profileuser‟.  You may also use a UNC path to if the user has a Home folder 
setup on the network. If „@profileuser‟ is used, it will be replaced with the current user‟s 
network login.  This is ideal for a Citrix or Terminal Server environment where you want to 
designate the data location. 

 Cache Enabled - Cache Enabled is designed to help speed up data requests for users on 
WebConnect. This setting is set to „Yes‟ by default. It should be changed to „No‟ unless the 
firm has mostly laptops that will be using the WebConnect feature. Citrix and Terminal Server 
environments do not require cache to be enabled since they are on the network already. 

 Interval – This sets the amount of time between cache synchronizations. This should be 
increased if workstations are constantly synchronizing the cache. This means 
synchronizations are overlapping and not completing. 

18. Place a check in Lock Settings at the bottom to prevent all the settings from being changed. 
 
*** IMPORTANT *** There is a potential issue for some clients that must be addressed before 
they deploy their database to 2.6.  Under Chart of Accounts, if there is a Conf Def Account 
present, it may conflict with an existing Chart of Account number the customer may have in place.   
See below. 

 
Before deploying, one of the duplicate accounts must be re-numbered so that there are no 
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duplicates.  See below.  Failure to do this will cause a failed deployment.   Once this is done, please 
proceed with deployment. 

 

Deploy JurisSuite Updates  

1. Click the Next button to proceed with the Deployment phase. 

2. The Deploy button has three choices.  Accept the default of „Deploy All‟.  This will ensure all of 
the components are updated properly.  Using the „Deploy Database‟ can be used to simplify the 
process for clients that have multiple databases.  Each database must be deployed with the 
updates.  Using the „Company‟ combo box on the initial Deployment Manager page allows for 
database selection. 

 

3. A window will display providing you with advice and the inquiry as to whether or not you want to 
make a Backup of the database during the deployment.  Click the Yes button. 



 

39 

The next screen is a review of documents (including this one) and acceptance of the review.  
Included are the Juris System Requirements, JurisSuite Upgrade Guide and the Installation 
Guide. Read the appropriate documents.  

 

Note: You must have a program to view the PDF format files.  Adobe Acrobat Reader is the most 
common and is available as a free download. 

4. Click inside the checkbox for „I have read and understand the System Requirements and 
Install Guide(s)‟ 
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5. Click the OK button.  The deployment will commence and check off the steps as they complete. 

 

6. When the deployment completes, depending on the outcome you will be prompted for one of 
these two items. Perform the step below that corresponds with the screen. 

a. If deployment is successful, click Yes to the prompt to delete the backup created. 
Continue to step 7. 

b. If deployment failed, click Yes to restore the backup created. After restoring, follow step 
8 and be sure to save the error log and call Juris Support at 877-377-3740. 

A deployment summary will disclose all the tasks that finished without error or with error.  
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7. Click the Next button. The Deployment Log window will appear. 

 

8. If you want to save a version of the log, click the Save Log button.  This will prompt you to save 
the log file with a .txt file extension.  You can also use the Copy button if you want to send the 
contents of the log to the Clipboard. Click the Finish button when complete. 

9. Click Yes to exit Deployment Manager. 
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Configuring Firm Settings 

Firm settings must be configured prior to using JurisSuite for the first time. 

1. Log in to Juris Suite as SMGR. 

2. Click the Juris button, point to Admin, and then click Firm Settings. The Firm Settings window 
opens. 

Note: Some Juris Suite modules in this procedure might not be available to you, depending on 
your purchase. If a module does not appear in the list, skip the steps for configuring that module‟s 
settings and continue with the rest of the procedure. 

3. Click Distributions in the list of modules on the left, and configure the following settings: 

 From Email Address: Change the email domain to your firm‟s domain. (Users cannot reply 
to this email address, and it does not need to be set up in Exchange.) 

 SMTP Host Address: Change this to the internal IP address of your firm‟s email server. (You 
can use the full computer name instead, but this may cause DNS issues.) 

 Webserver URL: Change this to the format SERVERNAME/JurisDistributedReports. 

4. Click Viewer in the list of modules on the left, and configure the following setting: 

 Dashboard Server URL: Change “localhost” to the name of your Juris server. 

5. Click Alerts in the list of modules on the left, and configure the following settings: 

 From Email Address: Change the email domain to your firm‟s domain. (Users cannot reply 
to this email address, and it does not need to be set up in Exchange.) 

 SMTP Host Address: Change this to the internal IP address of your firm‟s email server. (You 
can use the full computer name instead, but this may cause DNS issues.) 

6. Click Collections in the list of modules on the left, and configure the following settings: 

 From Email Address: Change the email domain to your firm‟s domain. (Users cannot reply 
to this email address, and it does not need to be set up in Exchange.) 

 SMTP Host Address: Change this to the internal IP address of your firm‟s email server. (You 
can use the full computer name instead, but this may cause DNS issues.) 

7. Close the Firm Settings window. 
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Configuring and Starting JurisSuite Services 

This is a requirement for the JurisSuite Business Intelligence, Juris Suite Collections, and JurisSuite 
Core Reporting Snap Ins to function properly. Skip this section if these modules were not purchased. 

1. Open services by going to Start> All Programs> Administrative Tools> Services. 

2. Scroll down to the JurisSuite Alert Service and JurisSuite Distributions Service. First we‟ll 
configure and start the JurisSuite Alert Service. 

 

3. Double click the JurisSuite Alert Service to bring up the JurisSuite Alert Service Properties 
window. 

4. In the Startup type drop down, select Automatic 
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5. Click the Start button to start the service. 

6. Click on the Recovery tab at the top. 

7. For First Failure, Second Failure and Subsequent failures, click on the drop down menu and 
select Restart the Service. 

 

8. Click the OK button to close out of the properties and accept changes. 

9. Repeat Steps 3 through 8 using the Juris Suite Distribution Service and the Juris Suite 
Collections Service. 

Enabling Juris Suite to Write to the Windows Event Log 

If the Juris Suite Server is installed on Windows Vista, Windows 7, or Windows Server 2008 and UAC is 
enabled, you must run a utility to enable Juris Suite to write to the Windows event log. 

To run the utility, double-click the executable file CreateJSEventLogSource.exe. The file resides in the 
following location on the server computer: 

C:\inetpub\wwwroot\JurisSuiteUpdater\JurisSuite\ 
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Creating a Pre-populated Cache (Optional) 

Firms with large databases or multiple users with cache enabled can save time on the back end by 
creating a pre-populated cache. This allows you to create the Cache from any Client PC and place it on a 
shared drive.  Make sure the folder or drive location has permissions set so that each user performing the 
import can access the file. This file is for the initial setup of a cache user only or if they have to rebuild 
and only needs to be created one time. It is recommended to perform exporting with everyone out of Juris 
and the database in Maintenance mode. This is to prevent changes to Juris database from corrupting the 
pre-populated cache file while it‟s being exported. The export process can take anywhere from 10 
minutes to 3-4 hours depending on database size.     

Note:  If cache is created on Windows 7 or Windows Server 2008, you must run as administrator. 

1. On the drive JurisSuite Client was installed, navigate to Program 
Files\JurisSuite\GeneralRelease. 

2. Locate and double click the executable file „Juris.Utilities.PrepopulatedCacheCreator.exe‟. 

 

3. Select the Company to Export.  You must do this for each company if you have more than one. 

4. Enter the path to save the cache file. Make sure that it is a location that can be accessed by 
those wanting to import.  You can also use the ellipses button to navigate to the location. 

5. Click the Export Cache button. 

 

6. Click the Yes button on the continuation window. 
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7. When the Export has completed. Click the OK button. 

8. Refer to the Juris Help file for instructions on creating the attachment add-on files (if needed). 

Publish the JurisSuite Dashboard Metrics 

This is a requirement for JurisSuite Business Intelligence Snap In to display data in the dashboards. 
Skip this section if the module was not purchased. 

1. Log into JurisSuite as SMGR. 

2. Click on the Business Intelligence snap in. 

 

3. Click on the Metrics Tab. 

 

4. Click Publish on the Metric Libraries tool ribbon. 

 

5. Click the Yes button to proceed. 

 

6. Click OK after the Metrics have been published. 
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Synchronize Schemas 

Synchronize Schemas is an important function that adds updated/changed information made to the 
Juris database table structure including metadata and UDFs (User Defined Fields). When you create a 
schema, it uses the metadata to display the tables and the fields.  If additional tables or fields have been 
added to the metadata, they will not be in the existing standard or custom schemas.  To make the fields 
available, you MUST run „Synchronize Schemas‟ to add that information to the existing schemas.  This 
is an Administrator only function 

1. Log In to JurisSuite as SMGR. 

2. Select the Synchronize Schemas function from the Utilities menu item. 

 

3. The Synchronize Schemas window will appear explaining the conditions of the function and 
whether you want to continue. Click Yes to continue. 

 

4. The process will begin and a status window will be displayed. 

 

Upon completion, a summary window will appear. 

 

5. You can click the Print Details button to print out the finished report. 

6. Click the Close button when finished. 
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Client 

Uninstall Previous MyJuris and JurisSuite Components 

1. Open Add/Remove Programs by going to Start>Control Panel> Add/Remove Programs. 

2. Locate and uninstall the following programs from the server (depending on what version was 
installed, you may not see all of the items below): 

 JurisSuite Client 

 MyJuris 

 Caution: When deleting folders, be sure to check the contents of the folder prior to deletion. This 
prevents accidental deletion of files that were improperly stored in the folder.  

3. Delete the following folders and all subfolders. 

 Program Files\Juris    (Not Juris2) 

 Program Files\JurisSuite 

Install JurisSuite Client 

1. Browse to the extracted install files on the network share and double click the 
JurisSuiteClient.exe file. 

 

 

2. Click the Next button on the Welcome window. 
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3. Accept the license agreement and click the Next button. 

 

4. Enter the appropriate Customer Information, and click the Next button. 

 

5. Keep the default of User and click Next. 
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6. Click Install 

 

7. When the installation has completed, click the Finish button.  

Client Configuration 

1. Click the Advanced down arrow. 

 

2. Replace ServerName for Web Update URL with the name of the server (for internal users) or the 
Outside IP Address (for WebConnect users). 

 

3. Click Test to validate the site. Then click Ok. 

4. Click Reset to Default Settings. 

5. Choose Yes to get a new configuration file. This will automatically populate the settings that were 
set in Deployment Manager and restart the program. 
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6. If WebConnect is required click Advanced again and select the Connection Type that the user 
will be mainly using. The default is „Auto Connect‟. The program is designed to choose the next 
lowest connection type if the selected fails. 

 

 Auto Connect – Allows the application to choose the connection. Recommended for Laptop 
that go between the office and home that does not have a VPN available. 

 Local Network – Used if you are on a LAN. Does not require cache. Recommended for 
Citrix/Terminal Server Client installations and desktop/laptop computers in the office or 
working off VPN. 

 Disconnected – Offline mode for users without an internet connection. Requires cache. 

 Web Connect – Allows you to remotely use JurisSuite via an Internet Connection. Requires 
cache and the WebConnect URL to be filled out. 

7. Set Cache Enabled to the appropriate setting for the above connection type. Cache Enabled 
“No” will automatically set the Connection type to Local Network. 

8.  Make note of the Interval times minutes. (Adjusted only for slower networks). 

 

9. Check the Lock Settings box to prevent accidental changes to the above settings. 

 
 

If cache is enabled for most of the company, it is strongly recommended to create a pre-populated 
cache to import initially to save time.  Use the Import Cache button to Import a saved pre-populated 
cache file on a shared drive. See Importing a Cache section of this document. 

Enabling Juris Suite to Write to the Windows Event Log 

If the Juris Suite client is installed on Windows Vista, Windows 7, or Windows Server 2008 and UAC is 
enabled, you must run a utility to enable Juris Suite to write to the Windows event log. 

To run the utility, double-click the executable file CreateJSEventLogSource.exe. The file resides in the 
following location: 

C:\Program Files (x86)\JurisSuite\GeneralRelease 



 

52 

Importing a Cache (Optional) 

After a new install of JurisSuite client, you can import the cache before logging in.  To import the saved 
cache, perform the following: 

1. Launch the JurisSuite application. 

2. On the log in screen, click the down arrow on the Advanced button. 

3. Click the Import Cache button. 
 

 

4. Navigate to the saved cache file location. 

5. Click Yes button to accept the import. 

6. When the import is complete, log in to JurisSuite. 

Conclusion for Upgrades from MyJuris 1.1 and JurisSuite Pre-2405 

This concludes the upgrade of JurisSuite. It is recommended that you go through the JurisSuite Settings 
and Permissions document before allowing users to use JurisSuite. This document can be found in our 
Additional Product Documentation section of the Juris Support Center.  

http://support.lexisnexis.com/lndownload/software/Juris/Docs/Juris_Suite_Permission_and_Settings_Recommendations.pdf
http://support.lexisnexis.com/lndownload/software/Juris/Docs/Juris_Suite_Permission_and_Settings_Recommendations.pdf
http://support.lexisnexis.com/juris
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Upgrades from 2405 and above versions of JurisSuite 

Server 

Download the Deployment and Setup Files 

1. Start JurisSuite Deployment Manager by going to Start>All Programs>Juris> JurisSuite 
Deployment Manager 

2. Click the Check Version button. 

 

Note: Version number will differ from the image above. It is only used as an example. If you want 
to review the release notes for the version listed, click the Release Notes button.  This will launch 
a separate window in the form of a browser. 

3. Click the drop down for the Download Version button and select Download All. 

 

4. Click the Download All button. 

 

5. After downloads are finished, close out of Deployment Manager. 

6. Navigate to the Staging Path and open the Setups folder. 
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Uninstall JurisSuite Server 

1. Open Add/Remove Programs by going to Start>Control Panel> Add/Remove Programs. 

2. Locate and uninstall the following programs from the server: 

 JurisSuite Server 

3. Open IIS Manager by going to Start> Programs> Administrative Tools> Internet Information 
Services 

4. Under Default Web Site right click and delete any of the following  sites if found 

 JurisSuite Updater 

 Juris Dashboard Server 

 Juris Distributed Reports 

 JurisSuite WebConnect 

Installing JurisSuite Server (If using Windows Server 2008, see page 4 for IIS6.0 
Compatibility Component Installation before proceeding) 

1. Navigate back to the Setups folder in the JurisSuiteStaging path and double click on the 
JurisSuiteServer.exe file to begin the installation. 

 

2. Click the Next button on the Welcome installation screen.  
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3. Select “Accept” on the license agreement window and click the Next button. 

 

4. Enter the appropriate Customer Information and click the Next button. 

  

5. On the Setup Type window, if JurisSuite is being installed to the Local Disk C: drive, accept the 

default of Complete, click the Next button and skip to step 7. Otherwise if installing on any drive 

other than C:\ you should select Custom and click the Next button.  
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6. From the Custom install screen, you will need to select the Updater combo box under the 
JurisSuite IIS Products.  Select “This feature, and all sub features, will be installed on local 
hard drive.”  

  

7. Click the Install button to execute the installation of the server application. 

  

8. Click the Finish button on the final window. 
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Configuration of IIS on Windows Server 2003 

To properly configure IIS for JurisSuite, perform the following: 

1. Start the IIS management console.  This can be accessed from within the Administrative Tools. 
Start > All Programs > Administrative Tools > Internet Information Services Manager 

2. Expand the server in the left hand pane. 

  

3. Expand the web sites. Right click on the JurisSuite Updater and select Properties.  
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4. On the Virtual Directory tab, click the Configuration button.  

  

5. Select .config extension, and click the Remove button. 

  

6. Click the Yes button to confirm removal of the extension. 

7. Click the Options tab, and place a check in the Enable parent paths box.  

  

8. Click the OK button. 
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9. Click the Directory Security tab. Click the Edit button under Authentication and access control. 

  

10. Place a checkmark next to the Integrated Windows Authentication if no checkmark exists.  
Click the OK button.  

  

11. Select the HTTP Headers tab.  Click the MIME Types button in the MIME types section. 

 

12. Click the New… button in the MIME Types window. 
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13. Enter each of the following types into the Extension and MIME type fields.  Be sure to add the 
period before each extension.  Click the OK button.  Repeat steps 13 and 14 until all the types 
are added. 

 .conf 

 .dat  

 .fmt 

 .isl 

 .msg 

 .sql 

 .config 

 

14. When you have completed, the window should look like the figure below.  Click the OK button 
when complete. 
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15. Click the ASP.NET tab. Select ASP version 4 from the ASP.NET version drop-down list. 

Note: For 64 bit servers, disregard this step. The ASP.NET tab will not appear when running a 64 
bit server in 32 bit mode. (32 bit mode is required for JurisSuite IIS sites.) 

  

16. Click the OK button on the JurisSuite Updater window. 

17. Right click on the JurisDashboardServer and select Properties.  

18. Click the ASP.NET tab. Select ASP version 4 from the ASP.NET version drop-down list. 

Note: If the ASP.NET tab does not appear, please refer to this Microsoft Support article: 
http://support.microsoft.com/?id=919283 

  

19. Ensure the C:\inetpub\wwwroot\JurisDashboardServer\ folder has full access to 

Network Services. 

Note:  If running Windows Server 2003, WebDAV, ASP.NET, and Active Server Pages have to be 
installed and allowed in IIS Web Service Extensions. 

20. Click the OK button on the JurisDashboardServer window. Close the Internet Information 
Services window. 

 

 

http://support.microsoft.com/?id=919283
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Confirm that JurisSuite IIS sites are running in ASP.NET 4.0 (Windows Server 2003) 

5. Click the Windows Start button and then click Run. The Run window opens. 

6. Type cmd and click OK. A command line window opens. 

7. Type the following commands, pressing ENTER after each one: 

cd/ 

c: 

cd windows\microsoft.net\framework\v4.0.30319 

aspnet_regiis -lk  

8. Confirm that you see JurisSuiteUpdater, JurisDashboardServer, JurisDistributedReports, 

JurisSuiteWebConnect, and JurisWebAPI as shown below. 

Note: Leave the command window open until you have confirmed that the sites are listed. 

 

If JurisSuite is installed in 32 bit mode correctly you will see a list of all 5 JurisSuite sites come up. This 
indicates that IIS setup Is complete. You can test the sites in Internet Explorer. 

If you do not see the sites (JurisSuiteUpdater, JurisDashboardServer, JurisDistributedReports, 
JurisSuiteWebConnect, and JurisWebAPI), follow this procedure: 

5. Click the Windows Start button and then click Run. The Run window opens. 

6. Type cmd and click OK. A command line window opens. 

7. Type each of the following commands, pressing ENTER after each one: 

cd/ 

c: 

cd windows\microsoft.net\framework\v4.0.30319 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteUpdater 

aspnet_regiis –sn W3SVC/1/ROOT/JurisDashboardServer  

aspnet_regiis –sn W3SVC/1/ROOT/JurisDistributedReports 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteWebConnect 

aspnet_regiis –sn W3SVC/1/ROOT/JurisWebAPI 

iisreset 

aspnet_regiis -lk  

8. Confirm that the list now shows JurisSuiteUpdater, JurisDashboardServer, 

JurisDistributedReports, JurisSuiteWebConnect, and JurisWebAPI. 

 

 

 



 

63 

Configuration of IIS7/Windows Server 2008 

1. Select Server Manager > Roles > Web Server (IIS) > Internet Information Services (IIS) 
Manager. 
 

 
 

2. Expand the server and sites node. 
 

 
 

3. Select Application Pools. 
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4. In the display pane, click the server name in the left pane. In the IIS area, double-click ISAPI and 
CGI Restrictions. 

 
 

5. Set the Framework applicable to the server‟s (64 or 32 bit) ASP.NET v4.0.30319 to „Allowed‟. 

6. In the display pane, right click on JurisSuite and select Advanced Settings. 
 

 
 

7. Ensure that the following settings are enabled: 

 (General) Section 
 

o .NET Framework Version – v4.0                 
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o Enable 32-bit Application – True (if you are running 64 bit machine) 
o Managed Pipeline Mode – Integrated 

 

 Process Model Section 
 

o Identity – Network Service 
o Load User Profile – True 

               

 
8. Click the OK button. 

9. Right click on JurisSuite and select View Applications. 

10. Ensure the following Applications are listed: 

o JurisDashboardServer 

o JurisDistributedReports 

o JurisSuiteUpdater 

o JurisSuiteWebConnect 
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Set JurisSuite IIS to run in ASP.NET 4.0 (Windows Server 2008) 

1. Click the Windows Start button and then click Run. The Run window opens. 

2. Type cmd and click OK. A command line window opens. 

3. Type the following commands, pressing ENTER after each one: 

cd/ 

c: 

cd windows\microsoft.net\framework\v4.0.30319 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteUpdater 

aspnet_regiis –sn W3SVC/1/ROOT/JurisDashboardServer  

aspnet_regiis –sn W3SVC/1/ROOT/JurisDistributedReports 

aspnet_regiis –sn W3SVC/1/ROOT/JurisSuiteWebConnect 

aspnet_regiis –sn W3SVC/1/ROOT/JurisWebAPI 

iisreset 

 

JurisSuiteUpdater Setttings 

1. Under Sites, select JurisSuiteUpdater. 
 

 
 



 

67 

2. In the IIS section, double click Request Filtering. 
 
Note:  In some instances, Request Filtering may not show as below even if it is installed.  Please 
refer to the following article on how to edit the Request Filtering file list via the 
ApplicationHost.config file.    http://support.microsoft.com/kb/942045/  
 

 

3. Ensure File Extension .config is set to „True‟. 

 

4. Return to the JurisSuiteUpdate site. You use the back browser button or simply re-select 
JurisSuiteUpdater under Sites. 

5. In the IIS section, double click ASP. 

  

http://support.microsoft.com/kb/942045/
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6. Ensure Enable Parent Paths is set to „True‟ 
 

 

7. Return to the JurisSuiteUpdate site. You use the back browser button or simply re-select 
JurisSuiteUpdater under Sites. 

8. In the IIS section, double click Authentication. 
 

 

9. Ensure Windows Authentication is set to „True‟ 
 

 

10. Return to the JurisSuiteUpdate site. You use the back browser button or simply re-select 
JurisSuiteUpdater under Sites. 

11. In the IIS section, double click MIME Types. 
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12. Right mouse click in the display pane and select Add.  You can also use the Add link under the 
Actions pane. 

 

 

13. Add the following types.  You must add one at a time, entering „text/plain‟ as the MIME type. 

o .conf 

o .dat 

o .fmt 

o .isl 

o .msg 

o .sql 

o .config 

 

Be sure to click the OK button each time to complete the additions. 
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14. In the display pane, click the server name in the left pane. In the IIS area, double-click ISAPI and 
CGI Restrictions. 

 

15. Set the Framework applicable to the server‟s (64 bit or 32 bit) ASP.NET v4.0.30319 to “Allowed”. 

JurisDashboardServer Settings 

1. Right click on the JurisDashboardServer and select Edit Permissions. 
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2. Select the Security Tab. 

3. Click the Advanced button. 
 

 

 
4. Select IIS_IUSRS as indicated below, and click the Change Permissions button. 
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5. Select the same IIS_IUSRS entry and click the Edit button. 

 

 

6. Ensure the Create files / write data and Delete subfolders and files is set to „Allow‟ 
 

 

7. Click the OK button.  Click the OK button on each of the open windows. 
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8. For theJurisDashboardServer, ensure Anonymous Authentication, Forms Authentication and 
Windows Authentication are enabled. 

                

 
 
 

9. Ensure the C:\inetpub\wwwroot\JurisDashboardServer\” folder has full access to Network 
Services 

10. Exit IIS Manager. 

JurisWebAPI Settings 

No special IIS7 settings are required for the JurisWebAPI. 

However, some additional setup is required to enable full API functionality. For details, please refer to the 
section JurisWebAPI Configuration and Usage. 

IIS7 Configuration is completed. 

*** IMPORTANT *** There is a potential issue for some clients that must be addressed before they deploy 
their database to 2.6.    If there is a Conf Def Account present, it may conflict with an existing Chart of 
Account number the customer may have in place.   See below.     

 

Before deploying, one of the duplicate accounts must be re-numbered so that there are no duplicates.  
See below.  Failure to do this will cause a failed deployment.   Once this is done, please proceed with 
deployment. 
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Deploying JurisSuite Updates  

1. Start JurisSuite Deployment Manager by going to Start > All Programs > Juris > JurisSuite 
Deployment Manager  

2. Click the Next button at the bottom to proceed with the Deployment phase. 

3. The Deploy button has three choices.  Accept the default of „Deploy All‟ to ensure that all 
components are updated properly.  Using „Deploy Database‟ can simplify the process for clients 
that have multiple databases.  Each database must be deployed with the updates.  Using the 
„Company‟ combo box on the initial Deployment Manager page allows for database selection.  

 

4. A window will display providing you with advice and the inquiry as to whether or not you want to 
make a Backup of the database during the deployment.  Click the Yes button. 
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5. The next screen is a review of documents (including this one) and acceptance of the review.  
Included are the Juris System Requirements, the JurisSuite Upgrade Guide, and the 
JurisSuite Installation Guide.  Read the appropriate documents 

.  

Note: You must have a program such as Adobe Reader to view the PDF format files. 

6. Click inside the checkbox for „I have read and understand the System Requirements and 
Installation Guide(s)‟ 
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7. Click the OK button.  The deployment will commence and check off the steps as they complete. 

 

8. When the deployment completes, depending on the outcome you will be prompted for one of 
these two items. Perform the step below that corresponds with the screen. 

a. If deployment is successful, click Yes to the prompt to delete the backup created. 
Continue to step 9. 

b. If deployment failed, click Yes to restore the backup created. After restoring, follow step 
10 and be sure to save the error log and call Juris Support at 877-377-3740. 

A deployment summary will disclose all the tasks that finished without error or with error.  



 

77 

9. Click the Next button. The Deployment Log window will appear. 

 

10. If you want to save a version of the log, click the Save Log button.  This will prompt you to save 
the log file with a .txt file extension.  You can also use the Copy button if you want to send the 
contents of the log to the Clipboard. Click the Finish button when complete. 

11. Click Yes to exit Deployment Manager. 
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Configuring Firm Settings 

Firm settings must be configured prior to using JurisSuite for the first time. 

1. Log in to Juris Suite as SMGR. 

2. Click the Juris button, point to Admin, and then click Firm Settings. The Firm Settings window 
opens. 

Note: Some Juris Suite modules in this procedure might not be available to you, depending on 
your purchase. If a module does not appear in the list, skip the steps for configuring that module‟s 
settings and continue with the rest of the procedure. 

3. Click Distributions in the list of modules on the left, and configure the following settings: 

 From Email Address: Change the email domain to your firm‟s domain. (Users cannot reply 
to this email address, and it does not need to be set up in Exchange.) 

 SMTP Host Address: Change this to the internal IP address of your firm‟s email server. (You 
can use the full computer name instead, but this may cause DNS issues.) 

 Webserver URL: Change this to the format SERVERNAME/JurisDistributedReports. 

4. Click Viewer in the list of modules on the left, and configure the following setting: 

 Dashboard Server URL: Change “localhost” to the name of your Juris server. 

5. Click Alerts in the list of modules on the left, and configure the following settings: 

 From Email Address: Change the email domain to your firm‟s domain. (Users cannot reply 
to this email address, and it does not need to be set up in Exchange.) 

 SMTP Host Address: Change this to the internal IP address of your firm‟s email server. (You 
can use the full computer name instead, but this may cause DNS issues.) 

6. Click Collections in the list of modules on the left, and configure the following settings: 

 From Email Address: Change the email domain to your firm‟s domain. (Users cannot reply 
to this email address, and it does not need to be set up in Exchange.) 

 SMTP Host Address: Change this to the internal IP address of your firm‟s email server. (You 
can use the full computer name instead, but this may cause DNS issues.) 

7. Close the Firm Settings window. 
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Configuring and Starting JurisSuite Services 

This is a requirement for the JurisSuite Business Intelligence and JurisSuite Core Reporting Snap 
Ins to function properly. Skip this section if both of these modules were not purchased. 

1. Open services by going to Start> All Programs> Administrative Tools> Services. 

2. Scroll down to the JurisSuite Alert Service and JurisSuite Distributions Service. First we‟ll 
configure and start the JurisSuite Alert Service. 

 

3. Double click the JurisSuite Alert Service to bring up the JurisSuite Alert Service Properties 
window. 

4. In the Startup type drop down, select Automatic 

 

5. Click the Start button to start the service. 
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6. Click on the Recovery tab at the top. 

7. For First Failure, Second Failure and Subsequent failures, click on the drop down menu and 
select Restart the Service. 

 

8. Click the OK button to close out of the properties and accept changes. 

9. Repeat Steps 3 through 8 using the JurisSuite Distribution Service.  

Enabling Juris Suite to Write to the Windows Event Log 

If the Juris Suite Server is installed on Windows Vista, Windows 7, or Windows Server 2008 and UAC is 
enabled, you must run a utility to enable Juris Suite to write to the Windows event log. 

To run the utility, double-click the executable file CreateJSEventLogSource.exe. The file resides in the 
following location on the server computer: 

C:\inetpub\wwwroot\JurisSuiteUpdater\JurisSuite\ 
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Publish the JurisSuite Dashboard Metrics 

This is a requirement for JurisSuite Business Intelligence Snap In to display data in the dashboards. 
Skip this section if the module was not purchased. 

1. Log into JurisSuite as SMGR. 

2. Click on the Business Intelligence snap in. 

 

3. Click on the Metrics Tab. 

 

4. Click Publish on the Metric Libraries tool ribbon. 

 

5. Click the Yes button to proceed. 

 

6. Click OK after the Metrics have been published. 
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Synchronize Schemas 

This is a requirement for JurisSuite Core Reporting Snap In to display data in the reports. Skip this 
section if the module was not purchased. 

1. Log In to JurisSuite as SMGR. 

2. Select the Synchronize Schemas function from the Utilities menu item. 

 

3. The Synchronize Schemas window will appear explaining the conditions of the function and 
whether you want to continue. 

 

4. The process will begin and a status window will be displayed. 
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Upon completion, a summary window will appear. 

 

5. You can click the Print Details button to print out the finished report. 

6. Click the Close button when finished. 
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JurisWebAPI Configuration and Usage 

Enabling PUT and DELETE 

By default, the PUT and DELETE verbs are not enabled for IIS7 and later. Follow these steps to 
enable PUT and DELETE manually: 

1. Open the file applicationhost.config as an administrator: 

a) Click the Windows Start menu. 

b) In the Search box, type notepad and press ENTER. 

c) In the list of search results, right-click Notepad and then click Run as administrator. (You 

might be prompted to confirm the action or to enter an administrator password.) The Notepad 

window opens. 

d) On the File menu, click Open. 

e) In the File name box, type: 

%windir%\system32\inetsrv\config\applicationhost.config  

f) Click Open. The configuration file opens in Notepad. 

2. Enable the PUT and DELETE verbs by changing this line: 
<add name="ExtensionlessUrl-Integrated-4.0" path="*." 

verb="GET,HEAD,POST,DEBUG" type="System.Web.Handlers.TransferRequestHandler" 

preCondition="integratedMode,runtimeVersionv4.0" /> 

to this: 
<add name="ExtensionlessUrl-Integrated-4.0" path="*." 

verb="GET,HEAD,POST,DEBUG,PUT,DELETE" 

type="System.Web.Handlers.TransferRequestHandler" 

preCondition="integratedMode,runtimeVersionv4.0" /> 

3. Ensure that WEBDAV does not interfere with your requests by making the following additional 

changes: 

a) Change this line: 
<add name="WebDAVModule" image="%IIS_BIN%\webdav.dll" /> 

to this: 
<!--add name="WebDAVModule" image="%IIS_BIN%\webdav.dll" /--> 

b) Change this line: 
<add name="WebDAVModule" /> 

to this: 
<!--add name="WebDAVModule" /--> 

c) Change this line: 
<add name="WebDAV" path="*" 

verb="PROPFIND,PROPPATCH,MKCOL,PUT,COPY,DELETE,MOVE,LOCK,UNLOCK" 

modules="WebDAVModule" resourceType="Unspecified" requireAccess="None" /> 

to this: 
<!--add name="WebDAV" path="*" 

verb="PROPFIND,PROPPATCH,MKCOL,PUT,COPY,DELETE,MOVE,LOCK,UNLOCK" 

modules="WebDAVModule" resourceType="Unspecified" requireAccess="None" /--> 

4. Save the file and close Notepad. 
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JurisWebAPI Help file Addendum 

Some settings in the web.config file require additional explanation: 
 

<add key = "SendNotificationEmails" value = "false" /> 

This must be set to TRUE so when clients and matters are edited or entered, an email will be sent. 
 

<add key = "SMTPAddress" value = "" /> 

The value must be entered by your firm on your SMTPAddress. 
 

<add key = "FromEmailAddress" value = "" /> 

The FROM email address when the email is sent regards to client and matters. 
 

 <add key = "ExpandNarrativeText " value = "true" /> 

When this is true, if there are text codes in the narrative, it will expand once POST command is run 
for time and expense entries.  If false, the narrative will not expand. 
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Client 

Upgrade JurisSuite Client 

Upon successful completion of the JurisSuite Server Upgrade, each individual client running the 
JurisSuite Client application will update automatically upon initial login. However, manual upgrading 
before sign on can be performed by following these steps. 

1. Click the Check for Updates button. 

 

2. Click Yes to the Check for Updates prompt. 

 

If the server is configured properly, the application will find the update and begin downloading.  

 

3. Once finished, the application will restart itself and the user may log into JurisSuite. 
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Rebuilding the Snap-In File 

A new snap in (such as Collections) added to Juris will not be available until the snap in file has been 
rebuilt. 

To rebuild the snap in file, click the Advanced button on the Login screen. Then click Rebuild Snap In 
File. Log in to Juris Suite and the snap in file will be rebuilt. 

Enabling Juris Suite to Write to the Windows Event Log 

If the Juris Suite client is installed on Windows Vista, Windows 7, or Windows Server 2008 and UAC is 
enabled, you must run a utility to enable Juris Suite to write to the Windows event log. 

To run the utility, double-click the executable file CreateJSEventLogSource.exe. The file resides in the 
following location: 

C:\Program Files (x86)\JurisSuite\GeneralRelease 

Conclusion of JurisSuite Upgrades for 2405 and higher Versions 

This concludes the upgrade of JurisSuite for 2405 and higher versions. It is not necessary to perform any 
settings or permissions changes after upgrading to this version.  
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